Too many connections

Error with code 1040 in '/var/www/livemaster/data/www/livemaster.hottabych.pp.ua/wa-system/database/waDbMysqliAdapter.class.php' around line 33:

   28	    {
   29	        $host = $settings['host'];
   30	        $port = isset($settings['port']) ? $settings['port'] : ini_get("mysqli.default_port");
   31	        $handler = @new mysqli($host, $settings['user'], $settings['password'], $settings['database'], $port);
   32	        if ($handler->connect_error) {
 >>33	            throw new waDbException($handler->connect_error, $handler->connect_errno);
   34	        }
   35	        
   36	        $charset = isset($settings['charset']) ? $settings['charset'] : 'utf8';
   37	        @$handler->set_charset($charset);
   38	        if (isset($settings['sql_mode'])) {

Call stack

#0 /var/www/livemaster/data/www/livemaster.hottabych.pp.ua/wa-system/database/waDbAdapter.class.php(30): waDbMysqliAdapter->connect(Array)
#1 /var/www/livemaster/data/www/livemaster.hottabych.pp.ua/wa-system/database/waDbConnector.class.php(49): waDbAdapter->__construct(Array)
#2 /var/www/livemaster/data/www/livemaster.hottabych.pp.ua/wa-system/database/waModel.class.php(72): waDbConnector::getConnection('default', false)
#3 /var/www/livemaster/data/www/livemaster.hottabych.pp.ua/wa-system/config/waAppConfig.class.php(339): waModel->__construct()
#4 /var/www/livemaster/data/www/livemaster.hottabych.pp.ua/wa-system/config/waAppConfig.class.php(243): waAppConfig->install()
#5 /var/www/livemaster/data/www/livemaster.hottabych.pp.ua/wa-system/waSystem.class.php(94): waAppConfig->checkUpdates()
#6 /var/www/livemaster/data/www/livemaster.hottabych.pp.ua/wa-system/waSystem.class.php(444): waSystem::getInstance('webasyst', NULL, true)
#7 /var/www/livemaster/data/www/livemaster.hottabych.pp.ua/index.php(7): waSystem->dispatch()
#8 {main}

Request

array (
)

Params

array (
)